Metadata improvement for ENS domains

Short and simple: I would like to suggest metadata improvements for ENS domains. It would be nice to see in the metadata how many numbers, letters, special characters there are in a name so people dont confuse 1 and l. This will give another tool for people to get the names and characters they want.

I do not know if this is possible but could be a great quality of life improvement.

As always, please leave your viewpoints open for discussion. Technical knowledge greatly appreciated.


This is coming up soon. @raffy is working on an E(NS)IP


@inplco Is the ENS metadata not being updated? I have records that are not updating on other sites (e.g., avatars).

1 Like

Not sure, I’ll have a look. Some apps don’t pull the metadata from chain every time; some of them do it once per week or something. Which apps did not have updated metadata?

PS. You can try using SIWE on this page and it pulls the metadata from chain actively: If the metadata is updated here, then your app is using local cached storage and not truly signing in with Ethereum.

opensea, looksrare, and gem. It has never been an issue before.

1 Like

It is possible that ENS Metadata Service is down. Let’s see if @serenae knows

Metadata service is up and running, but there are known issues with names that have non-standard characters in them:

Also, avatars do not currently work for domains with emojis or certain other characters:

Both of those issues are waiting on all the upcoming normalization changes:

You can check yourself directly on the metadata service, just replace your token ID in this URL:

Or for the NFT overlay image:

And if it’s still a mystery, and you don’t want to share the name publicly, create a ticket on Discord and I can take a look!


I may have made some assumptions that turned out wrong, as I had done so many from NFTs I created. I’m looking for Brantly avatar instructions

1 Like


1 Like

Yes! I think I was doing it right, so I’ll have to see where I went wrong.

1 Like


I own the ENS Tokens at issue.

Here is etherscan details:

Owner: berrios.eth-CBW-New

Contract Address:

ENS: Deployer

Token ID:

Token Standard:

Here is the text string: eip155:1/erc721:0x57f1887a8bf19b14fc0df6fd9b2acc9af147ea85/68314930446683028700038646130303125769541047778226756360671664268784887632587

TYA for your assistance

So you’re trying to set an avatar on 42usc1981.eth right?

What avatar do you want to set? Because that text string you shared is just using the contract/token for the ENS name.

I see that your avatar is currently set to:


But that NFT does not exist, at least not on-chain yet:

Most likely because you “created” an “NFT” on OpenSea, but it’s not really an NFT yet. It’s just in OpenSea’s private database. I believe you need to actually mint that NFT on-chain first. I think the simplest way to do that is transfer the NFT to yourself in the OpenSea UI, it should be an ETH transaction with gas fees.

1 Like

Yes! I’ve done this with nine different avatars already. The NFT avatars were created on opensea–minted yesterday. This is my first hiccup.

Sorry! I’m over thinking it!

Oh yeah huh… I do know that the OpenSea contract doesn’t follow ERC-1155 quite perfectly so the metadata service has some special code in there for that…

Anyway yeah the most recent one you linked should work, that is present on OpenSea. But the one that the name is currently pointing to I can’t find:

So if you update to that recent one you just linked, that should hopefully work


I stand corrected! I just had to correct the token ID. I was mixing things up.


Cool yep. Their contract just returns a parameterized URI for all those “not yet actual on-chain” tokens, it’s not really a true NFT until it’s minted on-chain, but OpenSea will still return metadata for them:{id}

So for your token it’d be:
    "name": "The Civil Rights Act of 1991",
    "description": null,
    "external_link": null,
    "image": "",
    "animation_url": null

That also means if OpenSea goes down, the “NFT” really is gone, because it doesn’t really reside anywhere else besides OpenSea’s private database!

1 Like

Tagging @mdt to make sure he sees this.

1 Like

I tried refreshing the metadata today and it did not work. The above string is correct. It is similar to the many others that did work flawlessly.

Once thing I forgot to mention is that I believe for NFT avatars, you need to have your ETH address record set, because I think (could be wrong) that’s the address it uses to check ownership of the NFT.

If the ETH address is not set, there’s a current bug in the metadata service where it doesn’t show avatars at all (either NFTs or regular URLs). I know @mdt was looking at that the other day and planning to roll out a fix for it!

1 Like

That could be it.

It works now. I had inadvertently deleted it.

1 Like