MM can’t resolve my ENS name

Hi folks,

I have a number of ENS registrations.
The first one I created I saw almost immediately reflected in MetaMask, so it clearly worked! That was quite exciting :slight_smile:

Then I registered - on a different ethereum address - 2 more ENS names.
MetaMask has never displayed a name for that address.
I considered the fact that because there were 2 ENS names registered to one ethereum address, this was perhaps why MM wasn’t displaying an ENS name (made perfect sense).
So yesterday I tried to solve this myself by removing the ETH address record for one of the 2 ENS names.
12 hours later however, MM is still not displaying the 1 ENS name for which there is still an address record.
Any tips on how to solve this so MM and any other Dapp can resolve my address to the ENS name? Only thing I can still think of is actually transferring the ENS nft to another address, is that necessary?

I think you should set the reverse record under My Account at .

Thanks, seems like I was confusing the different sections of the website.
I do think the UI is a little confusing however.
Will work it out though, thanks.

1 Like