Stuck registering a ens name

I am trying to register my name cryptoplanets.eth. My metamask wallet says “ALERT: Transaction Error Exception Thrown in Contract Code”. I have cancel or confirm. I don’t want to hit confirm on an error.
The fields on the screen are
Parent ETH
Registrant 0x9A77d199E25F579425740728712DB3bBFF4B229B
Controller 0x9A77d199E25F579425740728712DB3bBFF4B229B
EXPIRATION DATE 2020.05.28 at 01:02
Resolver 0X000000000000000000000000000000000000000
Then next line has address:
0xD3ddcCDD3b25A8a7423B5bEe360a42146eb4Baf3
When I click save, I get that error on my metamask.

I’m using Firefox 67.0 Ubuntu 16.04 LTS

Please advise.

are you the owner of this address? Looks like it’s already registered via this address.

This part I am not so sure where it’s appearing. Can you rather send us the full screenshot which gives us more clue diagnosing the issue.

  1. Yes, I am the owner of that address.

  2. Here is the screenshot from just now.


    Only there is a twist, I’m afraid. The screen is not the same as it was when I reported the problem. There is no submit button. I now have, “No Resolver Set.”
    (That original error message occurred within MetaMask, by the way.)

  3. and why is my address cryptoplan.eth? I registered for cryptoplanets.eth. Even says so in the URL. It’s for a blockchain venture, so I can’t be sloppy about the names I use.

It looks like you’ve successfully registered the name already.

You’re not setting any buttons to update the resolver because your browser is not currently signed in with the account that controls that name.

The display of ‘cryptoplan.eth’ is a recently introduced UI bug we should have a fix for momentarily; you own the full name.

Thank you, it looked like it worked. Yes, I opened MetaMask with a different wallet. When I tried with the first wallet, then yes it did give the next screen, and asked MetaMask to accept transaction, etc., etc.
However, at the end, I get this screen with invalid hex string.

It looks like you have set the resolver address to an external account. You need to set this to a resolver that can handle queries - generally you can click ‘use public resolver’ for this.

THAT DID IT!
Thank you for all your patience and help.