Switch from outdated resolver to public resolver

Hi there!

I have a problem switching from the outdated resolver to a public resolver in ENS Manager.
The resolver-adress says 'This resolver is outdatedand does not support the new content hash. Click the “Set” button to update to the latest public resolver."

I select ‘Use Public Resolver’ an the adress ‘0x226159d592E2b063810a10Ebf6dcbADA94Ed68b8’ shows up. I press save and the Metamask-Window opens a transaction
from: my .eth-account
to: 0x314159265dD8dbb310642f98f50C066173C1259b
GAS FEE 0,000032 / $ 0,01

I confirm the transaction and then metamask shows a ‘busy-circle’. Endless. Nothing happens.

The Metamask activity-protocol says ‘Set resolver’ failed.

Any ideas? I tried with higher gas. Same result.

Do you only see the issue when you setting new resolver or also get the issue for other operations (eg: changing your ethereum address). I once got similar metamask error when I was sending a transaction. Didn’t know why but the error disappeared when I tried the same a few days later.

Changing the adress does not work either.
Reason is the outdated Resolver.
Transaction from myname.eth to (outdated) resolver fails.

What about transferring the controller which is not related to resolver ?

Tried again today. No problems. Spooky.

@makoto: Thank you !

1 Like