Bulk Renewal - Repeated Failed Transaction

Hi Guys/Ladies

I keep hitting a wall when trying to bulk renew. Initially hitting gas limit, so mimicked successful transactions to change gas limit via metamask to 3000000. But still not going through, and costing me 20 USD every time! Had four failed transactions now, on names I am the controller on.

I am out of ideas of how to get these transactions to renew, failed contract error twice this time round.

Here are transaction IDs



Any help would be massively appreciated, i have literally hit the wall in terms of ideas on this one.

I looked like the transaction and it is failing because names you are trying to renew all expired and released. I also looked into the account used for renewal and all names were released. Which names are you trying to renew? I am surprised that you can see the renew button for released names.

hi, thanks for the reply

I was surprised they were still available and listed under my address as controller, I released eth for some names I had but these were all 0.01 eth so I left them, given Gas fees, they expired some time ago. I saw that they all were listed under my address as the controller, does that not mean I can renew the lease?


And yes I see renew for all the names under bulk renew. Looking further into it now, thanks.

We list controllers of released names purely because people who didn’t renew by accident can still figure out what names they used to own. Maybe we should add expiration data on the controller tab as well.

now I can see about 6 names under the registrant. I am guessing you managed to renew those?

Hi There, that sounds like a good idea. Or make it clear that name needs re registering.

The names gave me the bulk renew option and I tried to renew four times, as I assumed if the option was available. on the UI, it must be transactionally possible, so wasted a bunch of $ in gas! Live and learn, but yes would advocate the change. Thanks for getting back to me