Can not set address to my domain | Can not set primary ETH name for my domain

First issue: I tried to add addresses to my ETH domains however when I confirmed that I want to do that transaction was not generated and in console I received error:
fromPromise error: Error: cannot estimate gas; transaction may fail or may require manual gas limit (error={“code”:-32000,“message”:“execution reverted”}, method=“estimateGas”, transaction=

Second issue: I tried to set Primary ENS name but when I tried to pick some of it I saw only 4 of my 11 domains. What is the issue of that ??

In order to set a Primary Name for your address, the ENS name must first resolve to that address. That usually means just having the ETH address record set on that ENS name.

So set the ETH address record to the address you’re trying to set the Primary Name on. Once that’s done, when you connect as that address and go to the My Account page, that ENS name should now show up in the drop-down menu.

As for the gas issue, what wallet and browser are you using?

Wallet: Metamask, Browser: Brave

Oww about setting ENS Primary domain I think I got what you wrote. I need to set to my domain ETH address as my registrant/controller right ??

It doesn’t have to be the same as the registrant/controller necessarily, it just has to be set to the address that you want to set the primary name on.

This is assuming that you’re using the public resolver. It might be different if you’re using a different resolver contract. What is your resolver set to for that ENS name?

The public and default resolver is 0x4976fb03C32e5B8cfe2b6cCB31c09Ba78EBaBa41

I have 0x9C4e9CCE4780062942a7fe34FA2Fa7316c872956 as a Resolver but I think I know what you mean about how to set domain as a primary ENS name. I will add my address as ETH address and it should be ok I guess. Now someone need to solve this “gas estimate error” because currently I cannot set this address :slight_smile:

Okay, I guess that’s OpenSea’s resolver contract? I’m not too familiar with that or what it does or how it may differ from the public resolver, but hopefully that should be fine.

I would try disconnecting your wallet, closing the page, clearing your cookies / site data for app.ens.domains, then going back to the page and connecting your wallet again.

Still doesn’t work :frowning: