Claiming process failing at vote / sign step

Dear All,

I’m trying to claim my ENS but when I reach the voting / signing step the platform says sign, I sign with MetaMask but then it fails and ask to do try again.

Anyone else experiencing that?

If anyone sees this, I fix the issue by trying again on a different computer (mac) and it worked, didn’t work on windows.

I’m having the same issue and I don’t have a mac to try. Any ideas? Seen any way to fix this? Thanks.

Hi Derek, No I tried 10 times on a windows computer (reboot, reconnect the account etc…) and it never worked. It worked first try on a Mac.

Thanks for the response. I may wait to claim until the new year anyways at this point.

Didn’t work on a mac for me. Tried chrome and safari. Same problem as you. Wish there was some help.

Safari does not have a MetaMask plugin so I’m not sure we are talking about the same problem.

Yes I’m using trust wallet

I might have a solution for Windows users.
Had the same problem and I am using Chrome under Windows 10
My workaround went as following:

  • I have open a Crome window with Metamask

  • also open is an extra window with the claim process - lets call it “A”

  • I am stuck in A as everytime when i sign in Metamask I get “try it again” in A

  • now I open a 3rd window and open the claim process here as well - lets call this “B”

  • so A is still open and stuck

  • I try to confirm in B and then sign in Metamask

  • and it worked the very first try

Good luck to everyone !

1 Like

I am a Mac user. I have no difficulty with the process of claiming.
Please check with your own ENS account address.
Good luck!