ENS purchase won't complete

Tried to buy and register an ENS this morning, got stuck in step 1.
Payment used with MEW app, the confirmation prompt showed up and I confirm with that. Then nothing happen afterward on the ENS website.
Opened the chrome dev tools and see some errors, take a look at below:

Error: Number can only safely store up to 53 bits
at r (vendors.b42b09e6.js:850)
at o.toNumber (vendors.b42b09e6.js:850)
at Object.t.bufferToInt (vendors.b42b09e6.js:264)
at e._validateV (vendors.b42b09e6.js:407)
at new e (vendors.b42b09e6.js:407)
at k. (app.46826e8b.js:1)
at Object.h (vendors.b42b09e6.js:909)
at k.u.emit (vendors.b42b09e6.js:909)
at k.uiCommunicator (vendors.b42b09e6.js:784)
at k.dataReceived (vendors.b42b09e6.js:784)
at m.u.emit (vendors.b42b09e6.js:909)
at m.onData (vendors.b42b09e6.js:230)

Anyone has an idea?

P.S. I am not native speaker, sorry for my poor English

Hi. Can you try to register via app.ens.domains rather than MEW’s site. That’s third party registration site so we have very little knowledge over how their app works internally so we won’t be able to diagnose the error you just sent

Dear sir makoto, I tried both app.ens.domains website and MEW website. But still no luck
The errors were the same.

When I was doing with app.ens.domains, I connect wallet with MEW wallet. (currently I only have this one)
Therefore, I guess there is something wrong with MEW?
I would try other ethereum wallet as long as it is confirmed that the error only occur when used with MEW
( trying other wallet would cost, the fee is not cheap LOL)

I used Rainbow and it worked. Finally got my ENS.
Guess it was just some bugs of MEW.

1 Like