Is https://ensdomain.io scam?

I was clicking the access request link, and it redirects me to Participant Request and then to discord discord[DOT]com/channels/909358185951920159/916861004711874570, in discord they ask me to verify and it redirects me to https://ensdomain.io where they ask me to fill seed phrase for my wallet. Please help is the https:// ensdomain [dot] io official or not?

1 Like

Do not do it. It is a scam that has popped up before. Thanks for bringing it to our attention. @nick.eth @alisha.eth not sure who handles this type of thing.

3 Likes

Thank you for catching this. We’re fixing it right now.

4 Likes

so ensdomain[dot]io is unofficial?

It is fake. They want to steal your wallet seed phrase. Never share it with anyone.

1 Like

thanks Daylon. anyway, how to get invited to the real discord? I’m new here, and I would like to try and get the eth domain, thanks in advance

1 Like

The real discord is https://chat.ens.domains/.

Please DM me if you have any questions.

Thanks for this catch @gugki. The form has been updated. Also ensdomain[dot]io has been reported.

1 Like

I was trying to join to the ENS discord and ended up there. how to get to join to the real ENS discord? I kept getting “Unable to accept invite” from the https://chat.ens.domains ? is there any other invitation link? thank you

I had a similar issue a couple of months ago, I think the way I solved it was to navigate to https://ens.domains/ then hit Community (top right menu) and I got in from there. Obviously, feel free to navigate there yourself via your own means instead of clicking this link, but it should prompt you with a Captcha/login and then you should be sorted.

Hope that helps. Otherwise @alisha.eth or one of the community helpers can hopefully help you out. Just be sure to read the Discord channel rules on entry :slight_smile:

hi, I just tried it from the community tab, it returned the same “Unable to accept invite” unfortunately

hey @gugki, can you please clear your cache and try again. I’ve tried joining by clicking the Community link on the ens.domains site. I am able to connect to the Discord server with Chrome, Brave, Firefox and Safari, on desktop.

If you are still having trouble after clearing your cache, and trying a different browser, let me know. Please include details of the browser and device you are using.