New Registered Domain doesn't showup in my account

I have received a successful status message while registering a new Domain “Offshoreaccount” yesterday. But the domain doesn’t show up in my Metamask account or either can’t find it as an available domain on opensea.

Having this sort of issue for the 1st time. Can anyone help with a fix or throw light on how similar issue can be handled/resolved.

Transaction Detail:

1 Like

I am having the same problem. Bought connectivity.eth domain using Metamask. Domain is not showing up in Metamask (or opensea) but its there in my account on
Tranaction hash:

Also, contacted Metamask support and they suggested to add it as NFT. I tried that but it did not work. I keep getting the message that I dont own the domain and it cannot be added, which is totally false.

Since I am not getting help here , I posted this issue on Reddit. I was told there that if its shows up on etherscan it must show also on opensea when the wallet is connected. But to the contrary its just not showing up in opensea.

Same problem…
Transaction Det

1 Like

Found the reason, it is opensea’s problem. The data of the wallet and zapper are all from opensea, so they are not displayed. You can find your ENS on Rarible and sell it on this platform. Check your address on etherscan, you can also find your ENS on it

1 Like

Thanks Mate, for your effort. Happy to find it on rarible and list it out.

1 Like

Also understood, the issue is due to the backlog issue with Opensea and it will be show up in you account once the backlog is processed & cleared. Not sure about the timeframe though.

1 Like

Everywhere you can see my ENS except opensea. In opensea, only visible here: My profile → filter -->Collections (total)
Thanks everyone

since when has this been happening? we understand it can really be frustrating and we apologize.

I have bought another domain. Both are not showing up in metamask and opensea. Both domains bought this month.

1 Like

he following domains + 1 NFT have been stolen from my account today through a phishing attack . I had posted a request for assistance on there I received instructions from Sandeep_dev ( Unclaimed deposit on my ENS name but my wallet "owns 0 names to claim deposit" - #7 by shakarman ) to go to the site .

I was requested to give in my seed phase and which I did and nothing worked. I then releized that this may be a trap and checked my wallet. The 5 domains and 1 NFT were gone.
My address is 0x691118Bc6EBda4C746932e2a94D018382318136a
the wallet that stole the domains is
. The stolen domains are :

I have registered a poloce case as of today. you can contact me under . I will cancel the case if the domains are returned

Same problem…
Transaction Det

I’m having the same issue with two of my domains, but there is no pattern. I have older domains that show up in opensea and newer ones too. It seems very random.

Opensea is aware of the issue and is working on a fix.

I registered a .eth domain yesterday using Coinbase Wallet, and it didn’t show up in OpenSea. So I transferred that domain to a MetaMask Wallet, but it’s not showing up there either, however I can see it as “Unknown” on Rarible. Still doesn’t show in OpenSea.

I’m less concerned that I can’t see it on OpenSea and moreso that it’s listed as Unknown as an asset.

I could import a token in MetaMask, but I’ve only been learning about this for 48 hours so I wouldn’t know where to locate that information in .ens