Not possible to register .eth domains?

Hello, I am trying to register an .eth domain at

Finding available domain names is easy, but when you get to the registration screen, the “Request to Register” button is greyed out (not clickable). So there is no way to begin the registration process.

I am using Brave with an enabled crypto wallet. There are sufficient funds in the wallet. I’ve tried restarting the browser and reloading the page, but the button remains greyed out.

What am I missing here to start the registration process. Sorry if I’ve missed something obvious, I am still learning the ropes.

Thanks for any help with this.

Hi @perishable, have you tried to click the “connect” button on the top-left of the home page? I’m not sure whether Brave is supported since the screen only shows these 6 kinds of wallets. I’m using MetaMask and the function is OK.

Thanks for the reply. I have seen that button and clicked it, but do not have any of those wallets installed. From what I’ve read the wallet set up via Brave browser is enough. I guess that is not the case? I will try MetaMask and see if that works. Thanks again.


Here is the tutorial I am following:

Notice the first step:

“On desktop, this could be Chrome with the extension MetaMask, or the browser Brave with its Crypto Wallet enabled.”

I was trying to register .eth domain using Brave with its Crypto wallet enabled. It looks like that is not supported.

Using MetaMask worked. Thanks again for the help, cxp.