Registered ens name not found

The .eth domain name I just bought on is not found on OpenSea, even though I can find the verified transaction on Etherscan.
(Transaction Hash: 0xafaab8a1a20c0ea4dac137614c6934ce366ef14c9330d61423c8d1f84c5b0df6)

I have bought .eth domains without problems both before and after the one that is not found.

However, when I open my wallet it is there but looks ugly without the pretty image with the domain name on it.

Does anyone have any idea what the issue might be?


I also encountered the same problem


Opensea is aware of the issue and is working on a fix.

are you aware, that the problem exists for the same .eth domain on Opensea and MetaMask?

I can manualy integrate the missing NFT in MetaMask mobile, but it looks different than the other NFT’s/.eth domains and also doesn’t show in opensea after the manual integration in MetaMask.

Thank you

Opensea is aware of the issue and working on a fix.

But isn‘t this rather a problem on the ENS App?
The problem shows on MetaMask and OpenSea.

When the problem would be on OpenSea, there should be no problem in MetaMask, but it is.

I have the same issue. Says I own it in the ENS App but will not appear in MetaMask or Opensea. I own about 8 and this is the only one it does it for. I even transferred to another address to see if that would kickstart something but no luck.

Same problem with all names are visible, but some are displayed incorrectly. On everything is ok

I want to look behind this issue, can somebody give me an example of one that shows up and another that doesn’t? Testnet is also fine

This what you get in the wallet

Hi. Same issue here. I have other ENS domains but my latest domain is showing in Metamask (and therefore Opensea) as:

This is an unknown ENS name with the hash: 0xd5c17296d09061a2c9b2f20616885bd5568

@validator.eth - could you please advise who can resolve this? Obviously not an Opensea issue, as the error is present in my wallet after purchasing.

We can’t trade a domain name if a prospective buyer just sees ‘unknown domain’ rather than the actual name!

what is the name? Have you tried to refresh Opensea metadata? Is the name is showing up in the manager and Etherscan but not on Opensea?

Hi @validator.eth

Previously, the domain (00seven.eth) was showing in my account but was throwing an error in etherscan. Also wasn’t displaying properly in my wallet as mentioned above.

I refreshed metadata on OpenSea , as you advised, and it worked! It also, (I don’t understand how) sorted the problem in my Metamask wallet and the domain name is displaying properly now! I’ve seen quite a few people saying that they have this issue, so maybe it’s worth having this as a course of action in a FAQ section.

Thanks for your help

Metamask pulls it’s NFT data from Opensea, so if Opensea is displaying the name improperly (or not at all) it won’t show in Metamask. Glad you are all sorted out!

Thanks again - I appreciate the swift response.

Having the same issue - registered a couple of days ago but still not showing on opensea, and I’ve added it to my metamask (including token ID) but it just shows the token ID, not the nft itself. I have since purchased other NFT’s (not ens) and they are showing in my opensea profile.

Is there anything else I need to do or just wait a bit longer?