Request to run script to return WETH

My friend sent WETH to ENS ETH Registrar Controller by mistake.
Transaction Hash is here
0xf93805de05eb842d5a958955275cc5fe0d146826e61bd17efd59112ca1af60b6

I hope DAO accept to run script to return WETH to sender address.

Please help to us.

I think the DAO has the technical capability to return funds sent erroneously to the ETH Registrar Controller, unless I’m mistaken.

You’re certainly not the only one to make such a mistake. Curious to hear what others in the community think about this.

Of course, I don’t think the DAO would want to have to handle every single case like this on an individual basis. Maybe some kind of omnibus proposal to return various tokens sent by mistake from multiple people, and maybe it’s like a once every few years kinda thing.

If technically possible, which I’m not 100% it’s possible, then yeah I think the DAO would need to vote on that. Agree also if possible, this should be a one or two year event, and maybe a vote each time the returns are sent out so it’s not an agreement to do this infinitely into the future.

I’ve seen this happen a couple times. In most cases it’s probably user error, but still curious…

@Alan_0423 At one time I saw a user report that metamask failed to resolve an address, and metamask sent the tokens to the Registrar contract address. I believe that user sent some logs over to metamask for them to look at. I’m not sure where they are with that, or how this error technically happens. Just curious, was your friend using metamask? Did he copy and paste the Registrar controller and send the WETH? Or did they think they were sending to a .eth address, and the wallet ended up sending to the Registrar address?

Hi Zadok7, Thank you for your comment.
Please let me explain the detail about his situation and operation more.

At first, he created ENS address with his MetaMask address (sakimoto.eth) (0x186835536DB7f6463Ea09b4F8b354520A988E46E)
After that, he tried to create further ENS address (masamitsu.eth)
He said the process of registration for this ENS address was not smoothly completed at that time.
After a few days, he found “masamitsu.eth” in his MetaMask Recently sending list.
He thought the address registration was completed, then he sent WETH to “masamitsu.eth”.
(Actually he wanted to swap “WETH” to “ETH”, he is not understand crypto well)
So his operation is just sending WETH to “masamitsu.eth” on MetaMask.
But actual situation by Hash address, his WETH was sent to Registrar controller.

It’s not possible for the DAO (or anyone else) to recover tokens sent to the ETH registrar controller.

masamitsu.eth resolves to 0xC60B0Ee4eD95A89b53c0bF9A8268fa0B6e1140fF. If he sent to that address in MetaMask, the transaction would have been sent there, not to the .eth registrar controller.

1 Like

Judging by the transaction: https://etherscan.io/tx/0xf93805de05eb842d5a958955275cc5fe0d146826e61bd17efd59112ca1af60b6

It does indeed look like it was sent to the ENS Registrar controller.

Hi nick.eth, thank you for your comment.
One point I’m not clear is about this address 0xC60B0Ee4eD95A89b53c0bF9A8268fa0B6e1140fF.
Why is masamitsu.eth registered as 0xC60B0Ee4eD95A89b53c0bF9A8268fa0B6e1140fF.
He registered this ENS domain with his MetMask address, he have only one MetaMask and only one Account.

Indeed - but that would not have happened as a result of typing ‘masamitsu.eth’ into MetaMask as the destination address.

It was registered by that address 131 days ago: https://etherscan.io/tx/0x90e8a6aa39856dd3bacffebaebce8ad6f5fe87c68b678b87fe5fab5a59ebd480

Hi Cuthulu.eth, thank you for your comment.
Yes, I’m not understanding why WETH was sent to controller, even though he sent to ENS address “masamitsu.eth.”

Thank you for your information.
I see, “masamitsu.eth” was registered 131 days ago already…
The timing he tried to register this is just one month ago.
So the next question, why he could start process to register this domain ?
Normally system block to register duplicated domain, right ?
And another question, if existing the domain normally, why his WETH sent to controller ?

I’ve asked a few MetaMask users how they managed to send transactions to ENS contracts in the past, and in every instance they’ve copy/pasted or selected earlier addresses they’ve interacted with from within metamask.

My guess is that your friend did that accidentally. There is no way that sending something to masamitsu.eth would have sent it to the ENS registrar controller.

If we look at the code of the eth registrar controller we can see that it only has a withdraw ether function, it has no capabilities of interacting with tokens. It’s quite unfortunate. One of the big improvements in the NFT ERC over the Token NFT is that it has “safeTransfer”, which tests if the receiving contract supports sending tokens. It’s really unfortunate for Masamitsu, but their funds are now lost.

I understand your point.
I will confirm to my friend again, but I don’t think he copied the address of ENS controller also.

Thanks for the information everyone, this helps. I know that the core team is working on updates to the ETH Registrar Controller, so could that technically be changed in the future to add such capabilities?

I’m not saying we should necessarily, just wondering what the possibilities are!

Even if we add that capability it will only be enabled for the future contract, any tokens in this address will remain there.

Thank you for your information.
Please let me confirm my understanding…
The currently, ENS domain can be used for only ETH transfer, not support to other token like WETH.
Then WETH which was sent to ETH Registrar controller was already lost, we can not recover.
Finally the system will be improved as counter measure future.
Is my understanding correct ?

That is not quite correct. ENS names definitely can be used for other token transfers too, not just ETH.

Yes, the WETH that was sent to the controller contract in this case is, unfortunately, lost forever.

No, there are currently no plans to add those capabilities for future iterations of the controller contract.

Thank you for correcting me.
I understoodall your points.
how he sent WETH to ETH controller,
The possibility is only he inputted the address of ETH controller directly and sent…?

I don’t think he done like that…
But even any way he done, his WETH is not able to return, right ?

Yes, there is now no way to get that WETH back.

I also don’t know how that happened. Most likely he accidentally clicked on the controller contract (which was likely already saved in his Metamask address book) and sent without checking closely enough. You also said that he didn’t even mean to do an ERC-20 transfer anyway, he was trying to swap his WETH, and that he is new to crypto in general as well.

I got your point.
I’d like to say to here everyone thank you very much for your kindly support.

It’s very unfortunate result for my friend,
but I will inform this result, and advise to him that he should do operation with small amount first when he will do new operation.
It’s common sense in the crypto.