Stuck choosing a delegate to claim tokens

Setup:

  • Using chrome web browser for ENS claims site
  • Imported MEW wallet to MM using private key
  • See claimable tokens, successfully vote/sign

Problem on ENS Airdrop page, no delegates are loading to choose from. When I try to enter my delegate manually, I can add an address to delegate but when click through to the ENS Airdrop page, we are stuck with a gray box that reads “Checking delegate validity…”

Haven’t been able to get past this step. Anyone else having the same issue?

1 Like

I am having the exact same issue. None of the delegates are loading for me to choose from. I am unable to get pass this step.

1 Like

figured out the issue for me. I had to enable the metamask extension for “All Sites”

1 Like

This worked, thank you!

How did you enable Mm extension for all sites?

https://support.google.com/chrome_webstore/answer/2664769?hl=en

I’m having the same problem on Firefox (tor browser) and the metamask extension is already enabled for all sites. Any other suggestions to debug this?

EDIT: refreshing the page seems to have fixed it