Unable to register available domain


I am trying to register a domain that is labelled as available.
I have confirmed the first transaction (Step 1), but instead of waiting 1 minute (Step 2), I have been waiting for 1 day. :thinking:
I have tried refreshing and closing the page, but the process is still stuck.

Could you please advise on this?

Thanks! :slight_smile:


I just tried that 3 steps process this week for my video: but I did not meet your problem.

As you could see here (0:30-1:00)

I only could guess that in step2: someone tried to register the same name as you.

Maybe you could try again or other names in Ropsten testnetwork

Hi @robert,

Thank you for the information.
I was puzzled as to what exactly happened (I still am), but I think your explanation makes sense.

I will try to register the domain again from a different Ethereum account through Ropsten network.

Cheers. :slight_smile:

I can also not register a name. What should happen after the minute wait? Should the ‘Request To Register’ button change in ‘Register’ or do I need to click the ‘Register’ button above? When I click the top ‘Register’ button, in Edge and in Chrome nothing happens when I click that button.
Which register button

I use the MyEtherWallet plugin

Did you click on the “Request to register” button at the bottom of the screenshot?
That’s what you need to register.

I did click ‘Request To Register’, then waited for (more than) a minute and then clicked ‘Register’, but also tried ‘Request To Register’ again, but nothing happens the 2nd time.

I went to MyEtherWallet and tried there to create an ENS domain and there it worked, so I’m happy now…

Glad that it is all sorted now. :+1:t6:

But there is definitely a bug in their Back-end/API code.
Hopefully they will look at it soon enough.