Why is ens name not appearing in wallet, but it's in ENS controller?

ENS being registered are going here, which is the ENS controller.

How come the ENS names are not going to the wallet of the new owners that register the names?


That is the unwrapped ERC-721 for .eth 2LDs.

When you wrap a name, you are sending that ERC-721 NFT to the Name Wrapper contract. In return, you are issued a ERC-1155 NFT, representing the wrapped name.

If you unwrap a .eth 2LD, the reverse happens. The ERC-1155 wrapped NFT is burned, and the Name Wrapper returns you the original unwrapped ERC-721 NFT.

For example, this is the ERC-721 NFT for kbw.eth: https://opensea.io/assets/ethereum/0x57f1887a8bf19b14fc0df6fd9b2acc9af147ea85/78607364138462006508228283868592835466108196831935432071208482428845914418679

And this is the corresponding wrapped ERC-1155 NFT: https://opensea.io/assets/ethereum/0xD4416b13d2b3a9aBae7AcD5D6C2BbDBE25686401/60457258838063738456613033327347282325265393326775926996150928752508540193772

Also, names are wrapped by default when you register via the new manager UI.


yes that’s what happened, thank you.

I registered yev.eth in new manager UI. I received the erc-1155 and the wrapper contract received the wrapped name.

Since only one Primary ENS name is possible per wallet address, how do I get it to show cross-platform for this new ENS name that is the ERC-1155 in my wallet or the ERC-721 in wrapper contract?

Currently I still only see my other ENS name on 3rd party tools (yevm.eth but not yev.eth)

That shouldn’t affect the Primary Name at all. I see your primary name is set to yev.eth: - ENS

However I also see that the Etherscan page is out of date. I think Etherscan is just lagging behind or something.

1 Like

Makes sense. Will give it some time and see if other platforms (opensea, various ens tools) catch up this week.

Update on this… looks like Etherscan just doesn’t currently support Primary Names that are set via the registration transaction.

So to make it show up on Etherscan, go to the old v2 manager app: ENS App

On the My Account page, re-set your primary name to the same name (yev.eth). That should make it show up on Etherscan.

Shouldn’t be an issue for other places though. Like I see it already shows up correctly on OpenSea:

after having a minor heart attack, I also noticed this issue- namely ENS Vision no longer shows that I’m the owner of said wrapped name.

Good catch. Looks like it caught up on my of the sites.

Also, on ENS MyAccount, I clicked save to re-update it, and then it almost instantly got updated on Etherscan too. Thank you

glad you saw the thread too then! :slight_smile:

Sadly, i still couldnt solve it. I am in the new Ui and do not see any option to get my name added to etherscan.

Hi @lee-was-here.eth Do you see a button that says, “Set as primary name”? It would be on the profile view of your name once you are logged in to app.ens.domains. Setting that will associate your wallet address with your ENS name as its Primary name.

I dont see same option as you to set primary name.

It’s been set. OpenSea is showing it fine as well. If checking on Etherscan, there’s a bug in how they detect some set Primary names. The work around is to set it a second time, in a separate transaction, which unfortunately costs gas to do. You can use this tool to do that.

Hopefully the issue gets resolved soon on Etherscan’s end.


Hey there,

I tried setting my primary name again the second time using the tool you mentioned, but it’s still not showing up on etherscan. Would you mind taking a look at the parameters and see if it’s set correctly?

My ENS is: allahisbuying.eth

Thanks in advance!

Looks correct!

Etherscan is having more widespread Primary Name issues now actually, and not even manually re-setting the name works anymore for many people.

It should show up elsewhere, like Uniswap/Nftychat/OpenSea/etc. And you can open the Settings page in the ENS manager app and confirm it there too!


Noted. Thanks so much for checking for me! Cheers~

Hey guys!

This might help some of you? Not sure but;

Best and simplest way is to utilise the old manager app