Instructions: Find your ENS Claim Transaction on Etherscan

I see lots of posts here an in discord about people doing the claim and the tokens not showing up in their wallet. Some of this might be due to the fact that right now MM doesn’t show the $ENS token by default. But it is likely in your wallet.

All of your Ether and tokens (ERC-20, ERC-721, ERC-1151) are stored on the Ethereum blockchain, not in your wallet software. That means that it doesn’t really matter what your wallet says. It matters what the Ethereum blockchain says.

You can check what the blockchain says by pasting your wallet address or even better typing your easy to type and remember ENS name into the etherscan.io search box. Once you search it will display a page that says something like "The Ethereum Name (your ens name.eth) resolves to this address: 0xXXXXX.

Click the 0xXXXX to view your wallet on etherscan.

You will be able to find a transaction in the list that looks something like this.

If you try to do the transaction again, or if it failed for some other reason, it will show as failed. Like this:

Next you can look at the tokens. Back on the main page for your address, open the dropdown box for token. You will see your tokens in there. If you keep scrolling, you will also see the ENS NFTs (ERC-721 tokens). Or, click the little wallet icon next to the dropdown box to see your token holding all on a page. Thanks @noexit.

If you don’t have the $ENS token type in your MM wallet, see my other post on how to add it.

I hope this helps. I’ll close this out with… I’m here to help. I’ll try my best. I do not represent the ENS Foundation. I am a ENS hodler and delegate.

TRUST NO ONE, NOT EVEN ME!!!

Never give your private keys, seed phrase, or screen share with anyone saying they are helping you. They likely are not.

4 Likes

I find the “token holdings” screen rather useful… click the little box next to the drop down token list. It makes life much easier.

There’s also a neat multi-chain wallet viewer and limited Defi website called zapper:

https://zapper.fi/dashboard

I find this very useful for an overview of most tokens on L2 sidechains.

Added in to the instructions. Thanks for this.

I’m sorry that this has happened to you. ENS has nothing to do with someone accessing your wallet. That wallet has been transfered tokens from other wallets. If it is a hack of wallets than your will be in that list. I’m assuming this is your wallet based on the information you disclosed in this post.

What this means is they had access to your wallet and did the claim. There is a 0% chance that ENS has facilitated this because they have no access to your private keys.

This is a post about instructions, not help on a hack. I suggest you make a separate post.

1 Like

OK… Off Topic from OP - but.

This seems strange to me… The address you pulled shows the ENS record referred to by @rustyhenderson … but if I enter the .eth into etherscan it shows as available - if I search opensea, it’s not there - and ens manager says I can register it… but metamask resolves and address.

I guess I’m confused as to why etherscan doesn’t pull up an address with a search, but metamask does.

I didn’t blame you. But who else is to blame? Given how crypto works, especially ether, it is up to you to protect your wallet. I’m not saying you asked to be hacked but you came here accusing ENS of stealing your tokens or at least facilitating it. You should do some more research so you know how this stuff works.

Moses… Just gave you kudos in another message and you insult my intelligence in another. I am aware of how this works. If I mentioned ens management as being at fault, I misspoke and did not say it the way I should have. For that I apologize. I do know how it works, and if I had known it was hacked it wouldn’t have changed a thing because the wallet that was airdropped to could not be changed. Oh well. I’m still interested in ens and many other governance boards that I am currently involved in. With different wallets, and not as many armchair quarterbacks. I’m hoping my sad case helps someone somewhere. Then my 13k mistake would have been worth it. Thanks again moses.

These are your exact words. It sounds like you are saying ENS is at fault.

This can only be done by a site or service that has been granted access by ens.

thanks for your post, it helps me target my issue but still not solved. do you think is valid even for [ENS: Old Registrar] contract (https://etherscan.io/address/0x6090a6e47849629b7245dfa1ca21d94cd15878ef)?
seems i’m not eligible for ENS even if in the wallet i have this transaction:

aka years ago i played a bit with/registered a 2nd level .eth domain, but now i don’t own it anymore.

This guy. Moses I already apologized for my statement and retracted it. I in no way think ens was involved. Could the airdrop been handled differently, and additionally verification required, yes. It is what it is. As you have said several times, it is my fault and I will take it as a lesson learned.

You said “if”, I was just pointing out that you did. That is all.

Look, stop replying and making more comments if you won’t want me to point out when

  • You ignorantly blame ENS for allowing someone to access your wallet
  • You then say I insulted your intelligence as you know how this work. Clearly you didn’t otherwise you wouldn’t have blamed ENS and would have blamed yourself.
  • You then question if you did blame ENS at all, which I pointed out you did.

Just stop blaming others for your mistake then denying you did it, overestimating your knowledge in this space. Stop it with the victim mentality.

Honestly, I wish you would have the decency to not have posted in this thread at all as it is for instructions about a particular topic.

1 Like

I already apologized and admitted that I misspoke. I honestly wish you would grow tf up and move tf on. Let’s grow the community and forget that you have to have the last word and run small corners of the room. You were right. I was wrong. Good? Posts deleted for wrong topic. My apologies to the community and especially those who were affected by the hack. Good luck especially to Moses. This kid needs a hug for real.

Talk about moving on… move on, let’s see you move on.

1 Like