OpenSea "content not available yet" and missing ENS names

In the last few days OpenSea does not seem to be showing the standard background with the ENS name on it. Instead the ENS names “are not revealed”. An image showing “content not available yet” appears.


Other platforms like LooksRare do not have this issue, so it looks to be something on OpenSea side of things that needs to be fixed involving the way metadata is being read or updated. Here’s the comparison with LooksRare:


Not pushing one platform over another here. A search on Rarible for the same name shows it fine:


A few other things happening lately that might be related:

  • The ENS name can’t be found in a search on OpenSea.
  • The ENS name doesn’t appear under the collection of the owner.
  • OpenSea seems to have filters that may delist names for one reason or another. This has been in place already. However, delisting seems to have increased lately. Some of the delisted names make no sense as to why they are gone.

One example of a name that is completely missing is oshit.eth. When visiting the link for the asset it returns a “delisted” notice from OpenSea.

In order to find the link for an ENS name on OpenSea, that isn’t searchable or has been removed, you would append the tokenid to the end of the OpenSea URL (after the Registrar contract address)

You can find the right tokenid for the ENS name either on Etherscan, or it will also be in the URL of platforms that do list it. Just look at the last part of the URL and you’ll find the tokenid.

If you visit the link and OpenSea redirects, it means the name is delisted. This issue is different from the “content not yet available”/background reveal issue.



Yes, quite a few of my newly registered ENS were delisted by opensea platform, even including a normal 6-digit name. I think there are some bugs there.

1 Like

I think in some cases the names that show up as “delisted” actually just pop up later, as if it was some sort of lag on OpenSea’s side.

But some names are just stuck in that delisted state for days with no change too.

They’re not invalid names either, usually just normal [a-z] names


A few other points to add on this topic.

  • If an ENS name isn’t listed on OpenSea, most likely it won’t be seen on MetaMask mobile wallet. As I understand it, MetaMask uses some of the OpenSea APIs to read NFT data. So if the ENS name is not appearing in OpenSea and also not in the wallet, this may be why. Source of truth for ownership is on the blockchain, not any marketplace or wallet software.
  • A user reported they used the ENS App ( to transfer the Registrant to the same wallet. This seemed to have triggered OpenSea to show it correctly according to them. I’ve not verified this solution, and it does cost gas to do.

Hopefully OpenSea resolves whatever issue is happening. Names show fine on other major marketplaces as far as I can tell.

1 Like

For the delisted names, people are following this guide, it basically just manually refreshes the metadata:

That doesn’t fix the broken avatar issue though

1 Like

Still hasn’t been fixed it looks like.

Was talking to @Coltron.eth about this the other day… it’d be nice if the DAO had some way to get a status from the OpenSea dev side of things.

I don’t know if it’s all new names or just some of them, but the complaints and support tickets keep rolling in. Names being immediately delisted, or the avatars cannot be refreshed no matter what (Refresh Metadata does not work).

Also, that trick above doesn’t seem to be working anymore, at least not on the handful of names I’ve tried it on recently


This is the exact problem I’ve been having for some time. Ive got at least 120 domains ive registered either not showing up or content not available. Some domains have been registered for over 10 days that still will not show up or have “content not yet available”. I have also had 5-6 domains be delisted as well. A couple showed back up within an hour or so but some have not come back even when manually refreshing data. Ive also contacted OS several times and the last time I tried (4days ago) they never even responded. When OS did respond the only thing they could tell me was my domains were delisted for breach of terms and services. They could not specify any further. None of these domains had special character or Zero width characters

Another odd thing that keeps happening is domains that show “content not available yet” usually show the domain name below the avatar. However each day when I check to see if my domains are updated I have several names that previously appeared all showing “Unknown ENS name”. So no metadata and no name. If I refresh data on those they usually come back, but the the next day there are several more that do the same thing.

It’s very frustrating. I wish OS would at least give us some heads up as to a time frame to resolve this issue.

1 Like

I just tried the trick again, and it does work at least for the name I tried it with. It was delisted, and came back. One thing you’ll want to make sure is to refresh the page where you’re getting your graphql post request from. I think the tokens they issue expire, so if you’ve had the dev console open for awhile, try to refresh. You might already have tried this though, so it could just be OpenSea running into more issues. Not sure.

I kept the dev console open to fix people’s names for them, and noticed it does stop working if left open awhile. Probably an expired token to access the API?

Ill give it another shot and see. I have refreshed and closed the console a hundred times at this point lol. Maybe thats the issue, maybe I have requested a refresh too much and created a jam up?? IDK. Ive also logged out of OS, logged in with another wallet, the closed OS and logged back in with my original wallet and still no change. I’ll close out of everything now and the retry it and see what happens. Thanks!

What’s the .eth name? If you don’t want to post it here that’s fine, you can DM through twitter support, @ensdomains
Or create a ticket in the ENS Discord,

knix.eth is one of the older ones thats not loading metadata.

goatsy.eth is one that was delisted around the same time I registered Knix.eth.

wikilaw.eth is one of the many that I have that has the old ENS colors, which ive refreshed many times as well to no avail

Fixed it, it’s here now:

The issues with the background image/avatars is that OpenSea is just having problems refreshing that. It’s happening to pretty much all new names. Hopefully they resolve that soon.

Same issue with metadata. It used to work that if you refreshed the metadata on OS, it would update the name’s background to the newest blue color and updated font. That’s no longer happening. These names appear fine on other market places like LooksRare. Some users have shared OpenSea’s response and it seems to confirm they are working on some kind of solution, but I can’t say for certain when.

Thats strange. Was background not the standard blue background? I didn’t change the background so maybe it was from a previous owner? Either way, thank you for the help. At this point im just moving everything over to looksrare for now

1 Like

Since the name once existed, OpenSea is using a colored background from some time ago they generated I believe. I think if you hit refresh, you background might completely disappear on OpenSea but not sure. Yeah LooksRare seems to be functioning well.

Gotcha. Thanks again for the help!

Hi Zadok7,

Im having exactly the same issue on this one - got delisted. I have checked throughout different apps there is not special characters at all

Should be showing up here however is not

Contacted support and received the same stupid answer as player1ens…

Could you share some of your magic touch ?


1 Like

It’s showing now.

When this “content not available” issue is going to be solved by Opensea. Is there anyone who is in contact with Opensea.

It will get resolved by itself. Please remain patient. Sometimes it takes some 30 mins to 1 hour for the content to sync across OpenSea.